$re = '/(oh|msg)\s*(?=\{)(?:\{[^\{]*?\})/is';
$str = 'mSg
{ sda\\r\\n
sadsa\\r\\n
da\\r\\n};
//dfgdg
oh{fsdf}; jj
msg {ddd
msg
msg { sda\\r\\n
sadsa\\r\\n
da\\r\\n};
//dfgdfg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);