const regex = /(oh|msg)\s*(?=\{)(?:\{[^\{]*?\})/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(oh|msg)\\s*(?=\\{)(?:\\{[^\\{]*?\\})', 'gis')
const str = `mSg
{ sda\\r\\n
sadsa\\r\\n
da\\r\\n};
//dfgdg
oh{fsdf}; jj
msg {ddd
msg
msg { sda\\r\\n
sadsa\\r\\n
da\\r\\n};
//dfgdfg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}