using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(oh|msg)\s*(?=\{)(?:\{[^\{]*?\})";
string input = @"mSg
{ sda\r\n
sadsa\r\n
da\r\n};
//dfgdg
oh{fsdf}; jj
msg {ddd
msg
msg { sda\r\n
sadsa\r\n
da\r\n};
//dfgdfg";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}