re = /(oh|msg)\s*(?=\{)(?:\{[^\{]*?\})/i
str = 'mSg
{ sda\\r\\n
sadsa\\r\\n
da\\r\\n};
//dfgdg
oh{fsdf}; jj
msg {ddd
msg
msg { sda\\r\\n
sadsa\\r\\n
da\\r\\n};
//dfgdfg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end