#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\s?]+\?([abc]=[^&\n]*)(?:&(?1))*$"
Local $sString = "example.com?a=anything" & @CRLF & _
"example.com?a=anything&b=anything" & @CRLF & _
"example.com?b=any&c=any" & @CRLF & _
"example.com?a=anything&d=anything" & @CRLF & _
"example.com?e=anything"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")