package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s?]+\?([abc]=[^&\n]*)(?:&(?1))*$`)
var str = `example.com?a=anything
example.com?a=anything&b=anything
example.com?b=any&c=any
example.com?a=anything&d=anything
example.com?e=anything`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}