re = /^[^\s?]+\?([abc]=[^&\n]*)(?:&(?1))*$/m
str = 'example.com?a=anything
example.com?a=anything&b=anything
example.com?b=any&c=any
example.com?a=anything&d=anything
example.com?e=anything'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end