const regex = /^[^\s?]+\?([abc]=[^&\n]*)(?:&(?1))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s?]+\\?([abc]=[^&\\n]*)(?:&(?1))*$', 'gm')
const str = `example.com?a=anything
example.com?a=anything&b=anything
example.com?b=any&c=any
example.com?a=anything&d=anything
example.com?e=anything`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}