$re = '/^[^\s?]+\?([abc]=[^&\n]*)(?:&(?1))*$/m';
$str = 'example.com?a=anything
example.com?a=anything&b=anything
example.com?b=any&c=any
example.com?a=anything&d=anything
example.com?e=anything';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);