import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!\"#$%&'()*+,-.:;<=>?@[\\]^_`\\{|\\}~]).*).{8,10}";
final String string = "3J&pkeeN26\n"
+ "9cG3Z5#CD3\n"
+ "xB!34mUS7\n"
+ "Pn64@A^Vy\n"
+ "gY7!2PPXr\n"
+ "Yp955^*D\n"
+ "p$T2Zy62Q\n"
+ "Wd$X89UKh\n"
+ "b98wP#fk2\n"
+ "4Xx*4St%TY\n"
+ "9a3CW^&\n"
+ "9A3cWgk\n"
+ "ciao1988&\n"
+ "semPre\n"
+ "semPre2015\n"
+ "pn64@a^vy";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}