import Foundation
let pattern = ##"((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!"#$%&'()*+,-.:;<=>?@[\]^_`{|}~]).*).{8,10}"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
3J&pkeeN26
9cG3Z5#CD3
xB!34mUS7
Pn64@A^Vy
gY7!2PPXr
Yp955^*D
p$T2Zy62Q
Wd$X89UKh
b98wP#fk2
4Xx*4St%TY
9a3CW^&
9A3cWgk
ciao1988&
semPre
semPre2015
pn64@a^vy
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)