import re
regex = re.compile(r"((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!\"#$%&'()*+,-.:;<=>?@[\]^_`{|}~]).*).{8,10}")
test_str = ("3J&pkeeN26\n"
"9cG3Z5#CD3\n"
"xB!34mUS7\n"
"Pn64@A^Vy\n"
"gY7!2PPXr\n"
"Yp955^*D\n"
"p$T2Zy62Q\n"
"Wd$X89UKh\n"
"b98wP#fk2\n"
"4Xx*4St%TY\n"
"9a3CW^&\n"
"9A3cWgk\n"
"ciao1988&\n"
"semPre\n"
"semPre2015\n"
"pn64@a^vy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")