$re = '/((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!"#$%&\'()*+,-.:;<=>?@[\]^_`{|}~]).*).{8,10}/';
$str = '3J&pkeeN26
9cG3Z5#CD3
xB!34mUS7
Pn64@A^Vy
gY7!2PPXr
Yp955^*D
p$T2Zy62Q
Wd$X89UKh
b98wP#fk2
4Xx*4St%TY
9a3CW^&
9A3cWgk
ciao1988&
semPre
semPre2015
pn64@a^vy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);