const regex = /((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!"#$%&'()*+,-.:;<=>?@[\]^_`{|}~]).*).{8,10}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!"#$%&\'()*+,-.:;<=>?@[\\]^_`{|}~]).*).{8,10}', 'g')
const str = `3J&pkeeN26
9cG3Z5#CD3
xB!34mUS7
Pn64@A^Vy
gY7!2PPXr
Yp955^*D
p\$T2Zy62Q
Wd\$X89UKh
b98wP#fk2
4Xx*4St%TY
9a3CW^&
9A3cWgk
ciao1988&
semPre
semPre2015
pn64@a^vy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}