using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">([a-zA-Z0-9:.\-) ]{3,})<.*<input type=""checkbox"".*value=""([\d]*)""";
string input = @"<div class=""folderInfo""> [...] <p class=""folderName""><img src=""BILD"" class=""providerIcon"" height=""16"" width=""16"" alt=""BILD"" /><a href=""URL"" target=""_blank"">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href=""URL"" target=""_blank"">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type=""checkbox"" name=""chkFolder[]"" value=""5783608"" class=""chkFolder vtext-middle"" /></div>
<div class=""folderInfo""> [...] <p class=""folderName""><img src=""BILD"" class=""providerIcon"" height=""16"" width=""16"" alt=""BILD"" /><a href=""URL"" target=""_blank"">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href=""URL"" target=""_blank"">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type=""checkbox"" name=""chkFolder[]"" value=""5783609"" class=""chkFolder vtext-middle"" /></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}