import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">([a-zA-Z0-9:.\\-) ]{3,})<.*<input type=\"checkbox\".*value=\"([\\d]*)\"";
final String string = "<div class=\"folderInfo\"> [...] <p class=\"folderName\"><img src=\"BILD\" class=\"providerIcon\" height=\"16\" width=\"16\" alt=\"BILD\" /><a href=\"URL\" target=\"_blank\">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href=\"URL\" target=\"_blank\">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type=\"checkbox\" name=\"chkFolder[]\" value=\"5783608\" class=\"chkFolder vtext-middle\" /></div>\n"
+ "<div class=\"folderInfo\"> [...] <p class=\"folderName\"><img src=\"BILD\" class=\"providerIcon\" height=\"16\" width=\"16\" alt=\"BILD\" /><a href=\"URL\" target=\"_blank\">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href=\"URL\" target=\"_blank\">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type=\"checkbox\" name=\"chkFolder[]\" value=\"5783609\" class=\"chkFolder vtext-middle\" /></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}