use strict;
my $str = '<div class="folderInfo"> [...] <p class="folderName"><img src="BILD" class="providerIcon" height="16" width="16" alt="BILD" /><a href="URL" target="_blank">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href="URL" target="_blank">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type="checkbox" name="chkFolder[]" value="5783608" class="chkFolder vtext-middle" /></div>
<div class="folderInfo"> [...] <p class="folderName"><img src="BILD" class="providerIcon" height="16" width="16" alt="BILD" /><a href="URL" target="_blank">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href="URL" target="_blank">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type="checkbox" name="chkFolder[]" value="5783609" class="chkFolder vtext-middle" /></div>';
my $regex = qr/>([a-zA-Z0-9:.\-) ]{3,})<.*<input type="checkbox".*value="([\d]*)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}