$re = '/>([a-zA-Z0-9:.\-) ]{3,})<.*<input type="checkbox".*value="([\d]*)"/';
$str = '<div class="folderInfo"> [...] <p class="folderName"><img src="BILD" class="providerIcon" height="16" width="16" alt="BILD" /><a href="URL" target="_blank">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href="URL" target="_blank">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type="checkbox" name="chkFolder[]" value="5783608" class="chkFolder vtext-middle" /></div>
<div class="folderInfo"> [...] <p class="folderName"><img src="BILD" class="providerIcon" height="16" width="16" alt="BILD" /><a href="URL" target="_blank">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href="URL" target="_blank">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type="checkbox" name="chkFolder[]" value="5783609" class="chkFolder vtext-middle" /></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);