import Foundation
let pattern = #">([a-zA-Z0-9:.\-) ]{3,})<.*<input type="checkbox".*value="([\d]*)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="folderInfo"> [...] <p class="folderName"><img src="BILD" class="providerIcon" height="16" width="16" alt="BILD" /><a href="URL" target="_blank">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href="URL" target="_blank">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type="checkbox" name="chkFolder[]" value="5783608" class="chkFolder vtext-middle" /></div>
<div class="folderInfo"> [...] <p class="folderName"><img src="BILD" class="providerIcon" height="16" width="16" alt="BILD" /><a href="URL" target="_blank">[b]EIN NAME MIT SONDERZEICHEN[/b]</a><span>(<a href="URL" target="_blank">so</a> - Code: 2k8wfnnhdmhgr - 8.61 GB)</span></p> [..] <input type="checkbox" name="chkFolder[]" value="5783609" class="chkFolder vtext-middle" /></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)