#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\b(?!всемирный)\w*мир\w*"
Local $sString = "к примеру есть текст" & @CRLF & _
"" & @CRLF & _
"смирный армированный всемирный мир " & @CRLF & _
"" & @CRLF & _
"а как найти ВСЕ слова, что содержат мир, кроме всемирный? "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")