$re = '/\b(?!всемирный)\w*мир\w*/u';
$str = 'к примеру есть текст
смирный армированный всемирный мир
а как найти ВСЕ слова, что содержат мир, кроме всемирный? ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);