re = /\b(?!всемирный)\w*мир\w*/
str = 'к примеру есть текст
смирный армированный всемирный мир
а как найти ВСЕ слова, что содержат мир, кроме всемирный? '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end