use strict;
my $str = 'к примеру есть текст
смирный армированный всемирный мир
а как найти ВСЕ слова, что содержат мир, кроме всемирный? ';
my $regex = qr/\b(?!всемирный)\w*мир\w*/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}