using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!всемирный)\w*мир\w*";
string input = @"к примеру есть текст
смирный армированный всемирный мир
а как найти ВСЕ слова, что содержат мир, кроме всемирный? ";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}