const regex = /(?<!t)(?!^)t+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!t)(?!^)t+', 'gm')
const str = `kajshdkashdkjasd
tttttthjsdgfhjdsftdfgdfgtrttt
tttttthjsdgfhjdsftdfgdfgtwerwjktttttttttttkshkdgtttwewe
tttttthjsdgfhjdsftdfgdfgtsfskttttttjhksdjfgttkdjhg
asdkasd`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);