import Foundation
let pattern = #"(?<!t)(?!^)t+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
kajshdkashdkjasd
tttttthjsdgfhjdsftdfgdfgtrttt
tttttthjsdgfhjdsftdfgdfgtwerwjktttttttttttkshkdgtttwewe
tttttthjsdgfhjdsftdfgdfgtsfskttttttjhksdjfgttkdjhg
asdkasd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)