re = /(?<!t)(?!^)t+/m
str = 'kajshdkashdkjasd
tttttthjsdgfhjdsftdfgdfgtrttt
tttttthjsdgfhjdsftdfgdfgtwerwjktttttttttttkshkdgtttwewe
tttttthjsdgfhjdsftdfgdfgtsfskttttttjhksdjfgttkdjhg
asdkasd'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result