import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*::(.*?)\\('(.*?)',\\s'(.*?)'.*";
final String string = "{{ Form::label('events', 'Events') }}";
final String subst = "<$1 for=\"$2\">$3</$1>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}