use strict;
my $str = '{{ Form::label(\'events\', \'Events\') }}';
my $regex = qr/.*::(.*?)\('(.*?)',\s'(.*?)'.*/p;
my $subst = '<$1 for="$2">$3</$1>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";