using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^)(?=\D)";
string substitution = @"\n";
string input = @"A1B22C333";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}