const regex = /(?<!^)(?=\D)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^)(?=\\D)', 'g')
const str = `A1B22C333`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);