$re = '/(?<!^)(?=\D)/';
$str = 'A1B22C333';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;