use strict;
my $str = 'A1B22C333';
my $regex = qr/(?<!^)(?=\D)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";