using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|w+)*\})*\})*\})*\})*\})*\})*\})*\})*\})*\}";
string input = @"2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well.
ok: [goingwell] => {
""localresult"": {
""aa"":""bb"",
""aaa"":""bbb""
}
}
2016-03-21 21:36:31.172 INFO 17513 --- [main] Continue logging ...
2016-03-21 21:36:42.568 INFO 17514 --- [main] With more json strings...
ok: [xxa123] => {
""axaxaxa"": {
""aada"":""bb"",
""aaadfa"":""bbb""
}
}
2016-03-21 21:36:43.132 INFO 17515 --- [main] Continue logging ...
2016-03-21 21:36:45.428 INFO 17516 --- [main] With more json strings...
ok: [xxa123] => {
""ccc"": {
""ddd"": {
""eee"": {
""fff"": ""ggg""
}
}
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}