# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|w+)*\})*\})*\})*\})*\})*\})*\})*\})*\})*\}"
test_str = ("2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well.\n"
"ok: [goingwell] => {\n"
" \"localresult\": {\n"
" \"aa\":\"bb\",\n"
" \"aaa\":\"bbb\"\n"
" }\n"
"}\n"
"2016-03-21 21:36:31.172 INFO 17513 --- [main] Continue logging ...\n"
"2016-03-21 21:36:42.568 INFO 17514 --- [main] With more json strings...\n"
"ok: [xxa123] => {\n"
" \"axaxaxa\": {\n"
" \"aada\":\"bb\",\n"
" \"aaadfa\":\"bbb\"\n"
" }\n"
"}\n"
"2016-03-21 21:36:43.132 INFO 17515 --- [main] Continue logging ...\n"
"2016-03-21 21:36:45.428 INFO 17516 --- [main] With more json strings...\n"
"ok: [xxa123] => {\n"
" \"ccc\": {\n"
" \"ddd\": {\n"
" \"eee\": {\n"
" \"fff\": \"ggg\"\n"
" }\n"
" }\n"
" }\n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.