import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|\\{(?:[^\\{\\}]|w+)*\\})*\\})*\\})*\\})*\\})*\\})*\\})*\\})*\\})*\\}";
final String string = "2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well.\n"
+ "ok: [goingwell] => {\n"
+ " \"localresult\": {\n"
+ " \"aa\":\"bb\",\n"
+ " \"aaa\":\"bbb\"\n"
+ " }\n"
+ "}\n"
+ "2016-03-21 21:36:31.172 INFO 17513 --- [main] Continue logging ...\n"
+ "2016-03-21 21:36:42.568 INFO 17514 --- [main] With more json strings...\n"
+ "ok: [xxa123] => {\n"
+ " \"axaxaxa\": {\n"
+ " \"aada\":\"bb\",\n"
+ " \"aaadfa\":\"bbb\"\n"
+ " }\n"
+ "}\n"
+ "2016-03-21 21:36:43.132 INFO 17515 --- [main] Continue logging ...\n"
+ "2016-03-21 21:36:45.428 INFO 17516 --- [main] With more json strings...\n"
+ "ok: [xxa123] => {\n"
+ " \"ccc\": {\n"
+ " \"ddd\": {\n"
+ " \"eee\": {\n"
+ " \"fff\": \"ggg\"\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}