use strict;
my $str = '2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well.
ok: [goingwell] => {
"localresult": {
"aa":"bb",
"aaa":"bbb"
}
}
2016-03-21 21:36:31.172 INFO 17513 --- [main] Continue logging ...
2016-03-21 21:36:42.568 INFO 17514 --- [main] With more json strings...
ok: [xxa123] => {
"axaxaxa": {
"aada":"bb",
"aaadfa":"bbb"
}
}
2016-03-21 21:36:43.132 INFO 17515 --- [main] Continue logging ...
2016-03-21 21:36:45.428 INFO 17516 --- [main] With more json strings...
ok: [xxa123] => {
"ccc": {
"ddd": {
"eee": {
"fff": "ggg"
}
}
}
}';
my $regex = qr/\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|w+)*\})*\})*\})*\})*\})*\})*\})*\})*\})*\}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}