re = /\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|\{(?:[^\{\}]|w+)*\})*\})*\})*\})*\})*\})*\})*\})*\})*\}/
str = '2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well.
ok: [goingwell] => {
"localresult": {
"aa":"bb",
"aaa":"bbb"
}
}
2016-03-21 21:36:31.172 INFO 17513 --- [main] Continue logging ...
2016-03-21 21:36:42.568 INFO 17514 --- [main] With more json strings...
ok: [xxa123] => {
"axaxaxa": {
"aada":"bb",
"aaadfa":"bbb"
}
}
2016-03-21 21:36:43.132 INFO 17515 --- [main] Continue logging ...
2016-03-21 21:36:45.428 INFO 17516 --- [main] With more json strings...
ok: [xxa123] => {
"ccc": {
"ddd": {
"eee": {
"fff": "ggg"
}
}
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end