#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[a-zA-Z]:\\[^\\]+"
Local $sString = "H:\FirstFolderName\SecondFolderName\ThirdFolderName\File.ext"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)