const regex = /^[a-zA-Z]:\\[^\\]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]:\\\\[^\\\\]+', '')
const str = `H:\\FirstFolderName\\SecondFolderName\\ThirdFolderName\\File.ext`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);