// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[a-zA-Z]:\\[^\\]+").unwrap();
let string = "H:\\FirstFolderName\\SecondFolderName\\ThirdFolderName\\File.ext";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}