using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]:\\[^\\]+";
string substitution = @"";
string input = @"H:\FirstFolderName\SecondFolderName\ThirdFolderName\File.ext";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}