re = /^[a-zA-Z]:\\[^\\]+/
str = 'H:\\FirstFolderName\\SecondFolderName\\ThirdFolderName\\File.ext'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result