#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\[[^\}]+)?\{s*[^\}\{]{3,}?:.*\}([^\{]+\])?)"
Local $sString = "some Text dont care{ }" & @CRLF & _
"even Variables <html></html>" & @CRLF & _
"{\"Brisbane\":{\"HasAccess\":false,\"IsVesselAdmin\":true,\"IsCarsUser\":false},\"Sydney\":{\"HasAccess\":false,\"IsVesselAdmin\":true,\"IsCarsUser\":true},\"Melbourne\":{\"HasAccess\":false,\"IsVesselAdmin\":false,\"IsCarsUser\":false},\"Fremantle\":{\"HasAccess\":false,\"IsVesselAdmin\":false,\"IsCarsUser\":false},\"Test Terminal\":{\"HasAccess\":false,\"IsVesselAdmin\":false,\"IsCarsUser\":false}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")