$re = '/((\[[^\}]+)?\{s*[^\}\{]{3,}?:.*\}([^\{]+\])?)/m';
$str = 'some Text dont care{ }
even Variables <html></html>
{\\"Brisbane\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":true,\\"IsCarsUser\\":false},\\"Sydney\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":true,\\"IsCarsUser\\":true},\\"Melbourne\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":false,\\"IsCarsUser\\":false},\\"Fremantle\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":false,\\"IsCarsUser\\":false},\\"Test Terminal\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":false,\\"IsCarsUser\\":false}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);