# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\[[^\}]+)?\{s*[^\}\{]{3,}?:.*\}([^\{]+\])?)"
test_str = ("some Text dont care{ }\n"
"even Variables <html></html>\n"
"{\\\"Brisbane\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":true,\\\"IsCarsUser\\\":false},\\\"Sydney\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":true,\\\"IsCarsUser\\\":true},\\\"Melbourne\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":false,\\\"IsCarsUser\\\":false},\\\"Fremantle\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":false,\\\"IsCarsUser\\\":false},\\\"Test Terminal\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":false,\\\"IsCarsUser\\\":false}}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.