import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\[[^\\}]+)?\\{s*[^\\}\\{]{3,}?:.*\\}([^\\{]+\\])?)";
final String string = "some Text dont care{ }\n"
+ "even Variables <html></html>\n"
+ "{\\\"Brisbane\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":true,\\\"IsCarsUser\\\":false},\\\"Sydney\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":true,\\\"IsCarsUser\\\":true},\\\"Melbourne\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":false,\\\"IsCarsUser\\\":false},\\\"Fremantle\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":false,\\\"IsCarsUser\\\":false},\\\"Test Terminal\\\":{\\\"HasAccess\\\":false,\\\"IsVesselAdmin\\\":false,\\\"IsCarsUser\\\":false}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}