use strict;
my $str = 'some Text dont care{ }
even Variables <html></html>
{\\"Brisbane\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":true,\\"IsCarsUser\\":false},\\"Sydney\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":true,\\"IsCarsUser\\":true},\\"Melbourne\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":false,\\"IsCarsUser\\":false},\\"Fremantle\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":false,\\"IsCarsUser\\":false},\\"Test Terminal\\":{\\"HasAccess\\":false,\\"IsVesselAdmin\\":false,\\"IsCarsUser\\":false}}';
my $regex = qr/((\[[^\}]+)?\{s*[^\}\{]{3,}?:.*\}([^\{]+\])?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}