#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-+]?(?:\d+(?:\.\d*)?|\.\d+)"
Local $sString = "" & @CRLF & _
"123" & @CRLF & _
"sfg44" & @CRLF & _
"sgf -123" & @CRLF & _
"1" & @CRLF & _
"+1" & @CRLF & _
"113" & @CRLF & _
"12324" & @CRLF & _
"-" & @CRLF & _
"+" & @CRLF & _
"sfgsfsg 113.13" & @CRLF & _
".13 ssgfsf" & @CRLF & _
"-.23" & @CRLF & _
"-0.23" & @CRLF & _
"sfgsgf -134.14" & @CRLF & _
"+14.14" & @CRLF & _
"sfv" & @CRLF & _
"+sfv" & @CRLF & _
"-sfv" & @CRLF & _
"-3.1" & @CRLF & _
"." & @CRLF & _
"100%" & @CRLF & _
"" & @CRLF & _
"hsl(171, 100%, 92%)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")