const regex = /[-+]?(?:\d+(?:\.\d*)?|\.\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[-+]?(?:\\d+(?:\\.\\d*)?|\\.\\d+)', 'gm')
const str = `
123
sfg44
sgf -123
1
+1
113
12324
-
+
sfgsfsg 113.13
.13 ssgfsf
-.23
-0.23
sfgsgf -134.14
+14.14
sfv
+sfv
-sfv
-3.1
.
100%
hsl(171, 100%, 92%)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}